Difference between revisions of "SystemUpdater"

From RGDWiki
m (this bolding is unnecessary though i think the other ones are fine)
 
Line 24: Line 24:
   
 
== Surface ==
 
== Surface ==
On 09-02-2019, a user named '''Voodooween''' started DMing '''Trash_Bandatcoot''' about a specific TWL cartridge that can update to v1.4 and change regions. With no dumps being possible, Voodooween did send Trash_Bandatcoot screenshots to see the cart in action. At the time, both were not sure how the cartridge worked and how it operates.
+
On 09-02-2019, a user named Voodooween started DMing Trash_Bandatcoot about a specific TWL cartridge that can update to v1.4 and change regions. With no dumps being possible, Voodooween did send Trash_Bandatcoot screenshots to see the cart in action. At the time, both were not sure how the cartridge worked and how it operates.
   
On 1-5-2019, after conversations with d0k3, the creator of GodMode9, another user named '''Normmatt''' said that he has 3 SRL's versions, not only for v1.4a, but also for v1.4 and v1.3a. He also stated that the cartridge works on an IS-TWL-DEBUGGER and that it does contain devsigned TAD's. Later, the SRL files were made publicly.
+
On 1-5-2019, after conversations with d0k3, the creator of GodMode9, another user named Normmatt said that he has 3 SRL's versions, not only for v1.4a, but also for v1.4 and v1.3a. He also stated that the cartridge works on an IS-TWL-DEBUGGER and that it does contain devsigned TAD's. Later, the SRL files were made publicly.
   
 
== Available versions==
 
== Available versions==

Latest revision as of 10:49, 8 June 2019

SystemUpdater
SystemUpdaterMenu.png
Picture of v1.4a, running on No$GBA
Cart IDNTRJ
Found versionsv1.3a, v1.4, v1.4a
Cart AppearanceA white reflashable Nintendo cartridge
Cart Release Date2010-04-15 (v1.4a)

The SystemUpdater is a collection of cartridges/SRL files that allow you to update or downgrade an IS-TWL-DEBUGGER. These were mainly used for development consoles, and they do not work on retail units.

Features

The features for this cartridge are very simple. The cartridge contains updates for all regions (including China and Korea since v1.4) and they will be installed when selected. When a region has been selected, all the data will be deleted from the NAND and devsigned TAD's will be installed. Unlike regular TWL carts and exploits that do not have NAND access, this one does. If done correctly, the tickets, TWLCFG0.dat, TWLCFG1.dat and the system menu, with the bundled DSi applications have been installed. TwlNmenu and NandFiler are optional.

The cartridge can also detect if you're on a Panda or Debugger. If 16MB of memory is found, it will be listed as TWL CONSOLE (Panda, IS-TWL-CAPTURE). If 32MB of memory is found, it will be listed as IS_TWL_DEBUGGER.

Surface

On 09-02-2019, a user named Voodooween started DMing Trash_Bandatcoot about a specific TWL cartridge that can update to v1.4 and change regions. With no dumps being possible, Voodooween did send Trash_Bandatcoot screenshots to see the cart in action. At the time, both were not sure how the cartridge worked and how it operates.

On 1-5-2019, after conversations with d0k3, the creator of GodMode9, another user named Normmatt said that he has 3 SRL's versions, not only for v1.4a, but also for v1.4 and v1.3a. He also stated that the cartridge works on an IS-TWL-DEBUGGER and that it does contain devsigned TAD's. Later, the SRL files were made publicly.

Available versions

With the updater comes a HTML file for instructions and troubleshooting. On the bottom of the page, is a changelog listed.

RevisionHistory.png
Confirmed image of the cartridge. Same cartridge used for TWL prototypes and other development applications.
The main menu, showing a selection of regions.
You can cancel the update by pressing B, freezing the menu, forcing you to restart.
The menu asking you if you want to continue.
The menu testing if it can write to the NAND. It copies TWLCFG#.dat files afterwards.
The updater failing to install, due to devsigned TAD files.
The updater completing the installation. You have to turn off the DSi yourself.

Notes

  • Holding SELECT and A at the same time when continuing an update skips the installation for TwlNmenu and NandFiler. This was mainly for retail units, despite these carts not working on retail units without modification.
  • Instead of the version number being (eg.) v1.4E, it says v1.4E_dev, notifying you it has been updated using a SystemUpdater cartridge.
  • The dev-version cannot import or export .bin files from the system settings like a retail unit. It can only delete applications, therefore, TwlNmenu must be used.
  • v1.4 were not availible in China and Korea. Around that time, Nintendo and iQue were still dealing with the goverment in order to get their games released. This means that these are the earliest K & C versions availible.